Forum Index


Support myDVDEdit

Register Register
Log in Log in

Search Search
FAQ FAQ



--- Links ---
MacEtVideo
VideoHelp
Forum Mac-Video
 
(#91) Critical bits Trashed on load, everything haywire on Empty
Forum Index -> Bug Reports
Author (#91) Critical bits Trashed on load, everything haywire on Empty
mike
Member
Member   



Joined: 21 Jul 2009
Posts: 8

PostPosted: Mon 01 Mar 2010, 03:11 Reply with quote
Type:  Bug Report
 
Last change:  Mon 08 Mar 2010, 12:42
State:  Closed Based on version:  1.1 (v55)
Level:  Low Fixed version: 

Hi Jerome,

I'm having problems with all 3 discs from a DVD box set. There was some sort of nastiness in the originals - MTR failed spectacularly with many "this disc was authored with bad sectors" alerts. However, Ripit seemed to cope and the resulting rips play without any problems.

On loading into myDVDEdit, all 99 (!) titles throw up "bad sector number" errors. All are reported as fixed. Most are reset to 0; the rest are changed to only 4 unique numbers, each used multiple times. There's a whole bunch of stuff in the Trash. At this point, the project can be saved and still plays OK. The displayed DVD bytesize looks correct.

Debugging hits a wall when it tries to jump to VTS Menu 2, which is one of the things in the Trash.

The spectacular fireworks happen when emptying the trash. The DVD bytesize readout now shows a large negative number (approx -2x the original size; confused by duplicate references?). If I now try to save, I get a ".VOB changes recording" progressbar with an estimated time of about 4 days. It actually finishes quite quickly; VOBs are still there, and if I close and reopen then the bytesize is back to normal, but the DVD looks to have been corrupted and now beachballs DVD Player.

I've tried importing an individual VTS into an empty shell DVD; it exhibits the same symptoms on a smaller scale.

I can mail .IFOs if it helps.

Thanks,
Mike
Back to top
View user's profile Send private message
Reply to topic
Author Message
Jerome
Administrator
Administrator   



Joined: 18 Jul 2005
Posts: 460
Location: France

PostPosted: Fri 05 Mar 2010, 11:57 Reply with quote

It's not really a myDVDEdit bug. Your DVD files are intentionally corrupted by the majors to prevent it's copy.

Nevertheless, if you want I look at your problem, I will need all the DVD files. The .IFO files will not be enough in your case because the emptying trash operation touch the .VOB files.

If you can reproduce the problem with a "not too big" DVD folder, you could send it to me with a tool like http://dl.free.fr (in french)

Jerome
Back to top
View user's profile Send private message Visit poster's website
mike
Member
Member   



Joined: 21 Jul 2009
Posts: 8

PostPosted: Sat 06 Mar 2010, 01:39 Reply with quote

Fair enough. I've never quite understood the deal with these "intentionally corrupted" DVDs, though - if they don't follow the spec, how do they manage to play on all the various players out there?

These are commercial discs (specifically, this set) so I can't upload the rips. I'd be happy to buy you a set, though, if you can cope with Region 1. (I've just discovered that amazon.fr has it in Region 2, dammit. Here in the UK we seem to get all the good stuff late.)

Incidentally, you mentioned in this reply that you were working on a single-title import function. Is that still in the pipeline? I suspect that would bypass the problem neatly, since the individual playable titles (as opposed to VTSes) look OK.

UPDATE: just tried re-ripping with the new Ripit 1.4 release with much better results; clearly the bug was there. The trash/empty-trash issue still exists, but now only affects 3 VobIds; myDVDEdit shows one entry each in the VTS-level Cells display for three VTSes, referencing these VOBs, but none of the PGCs in those VTSes contain any cells. Deleting the PGCs hangs the window (not the app) at the confirmation prompt. I've raised this remaining glitch with Ripit; apologies for the false alarm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Forum Index -> Bug Reports Page 1 of 1

 
Jump to:  

Powered by phpBB © 2001, 2017 phpBB Group